Cisco Patches Security Appliances

Wednesday, July 3, 2013 @ 09:07 AM gHale


Cisco Systems released security patches for its email, Web and content security appliances in order to fix vulnerabilities that could allow attackers to execute commands on the underlying OS or disrupt critical processes.

The vulnerabilities affect different versions of the Cisco IronPort AsyncOS operating system used in the Cisco Content Security Management Appliance, the Cisco Email Security Appliance and the Cisco Web Security Appliance.

RELATED STORIES
LinkedIn Outage Caused by DDoS
Self-Propagating Trojan Lives On
BIND 9 DoS Hole Patched
P2P Botnets Keep Growing

Releases 7.1 and prior, 7.3, 7.5 and 7.6 of the software in the Cisco Email Security Appliance suffer from three vulnerabilities, one that allows remote attackers to inject and execute commands with elevated privileges through the Web interface and two that could be used to crash the management graphical user interface (GUI) or the IronPort Spam Quarantine service and cause other critical processes to become unresponsive.

Exploiting the command injection vulnerability requires authentication via the Web interface with at least a low privilege account, but the denial-of-service vulnerabilities can end up exploited remotely without authentication.

Users of the 7.1 branch should upgrade to version 7.1.5-016 or later, users of the 7.3 branch should upgrade to version 8.0.0-671 and users of the 7.5 and 7.6 branches should upgrade to 7.6.3-019 or later, Cisco said in a security. Releases in the 8.0 branch do not suffer from the issue.

Branches 7.2 and prior, 7.7, 7.8, 7.9 and 8.0 of the Cisco Content Security Management Appliance software suffer from the same command injection and denial-of-service vulnerabilities as the Cisco Email Security Appliance software.

Cisco patched all the vulnerabilities in versions 7.9.1-102 and 8.0.0-404, Cisco said in a separate advisory. Users of 7.2 and prior, 7.7 and 7.8 branches should upgrade to version 7.9.1-102 or later of the software. The 8.1 versions do not have the issue.

Releases 7.1 and prior, 7.5 and 7.7 of the Cisco Web Security Appliance software are vulnerable to two authenticated command injection vulnerabilities and one management GUI denial-of-service vulnerability. Some of the vulnerabilities are the same as those affecting the Cisco Email Security Appliance software.

The software releases that include fixes for all three Cisco Email Security Appliance vulnerabilities are 7.5.1-201 and 7.7.0-602. Users of the 7.1 and prior versions should upgrade to 7.5.1-201 or later, Cisco said.



Leave a Reply

You must be logged in to post a comment.