GE Clears Multilin SR Protective Relays Hole

Thursday, April 27, 2017 @ 02:04 PM gHale


GE created new firmware to mitigate a weak cryptography for passwords vulnerability in its Multilin SR Protective Relays product, according to a report with ICS-CERT.

Successful exploitation of this vulnerability may allow a remote attacker to obtain weakly encrypted user passwords, which could end up used to gain unauthorized access to affected products.

RELATED STORIES
Hyundai Updates Blue Link App
Sierra Wireless Mitigates Vulnerabilities
BLF-Tech LLC VisualView HMI
Update to ‘BrickerBot’ Attack

GE reported the vulnerability to ICS-CERT. New York University security researchers Anastasis Keliris, Charalambos Konstantinou, Marios Sazos, and Dr. Michail (Mihalis) Maniatakos initially discovered the issue.

The following versions of Multilin SR protective relays suffer from the remotely exploitable vulnerability:
• 750 Feeder Protection Relay, firmware versions prior to Version 7.47
• 760 Feeder Protection Relay, firmware versions prior to Version 7.47
• 469 Motor Protection Relay, firmware versions prior to Version 5.23
• 489 Generator Protection Relay, firmware versions prior to Version 4.06
• 745 Transformer Protection Relay, firmware versions prior to Version 5.23
• 369 Motor Protection Relay, all firmware versions

No known public exploits specifically target this vulnerability. An attacker with a low skill level would be able to exploit the vulnerability.

Cipher text versions of user passwords were created with a non-random initialization vector leaving them susceptible to dictionary attacks. Cipher text of user passwords can be obtained from the front LCD panel of affected products and through issued Modbus commands.

CVE-2017-7905 is the case number assigned to this vulnerability, which has a CVSS v3 base score of 8.1.

The product sees use in the chemical, critical manufacturing, dams, energy, food and agriculture, government facilities, transportation systems, and water and wastewater systems. The product sees action on a global basis.

GE released the following firmware versions, which remove access to the cipher text from the front LCD panel and through Modbus in the affected products:
• 750 Feeder Protection Relay, Version 7.47
• 760 Feeder Protection Relay, Version 7.47
• 469 Motor Protection Relay, Version 5.23
• 489 Generator Protection Relay, Version 4.06
• 745 Transformer Protection Relay, Version 5.23

GE is planning to release a firmware update for the 369 Motor Protection Relay in June 2017.

GE recommends users apply updated firmware versions to affected products, as well as implement the following physical security and network security defensive measures:
• Control access to affected products by keeping devices in a locked and secure environment
• Remove passwords when decommissioning devices
• Monitor and block malicious network activity
• Implement appropriate network segmentation and place affected devices within the control system network, behind properly configured firewalls. Protection and Control system devices should not be directly connected to the Internet or business networks

Click here for the GE security advisory, SR-2017-00001 Multilin SR Family of Protective Relays.



Leave a Reply

You must be logged in to post a comment.