Patched OpenSSL Hole Still an Issue

Wednesday, June 1, 2016 @ 12:06 PM gHale


When to patch and when not to patch is a very difficult decision.

In an industrial environment, the topic is the cause of an ongoing debate just because systems cannot go down every time a patch need implementing.

RELATED STORIES
OpenSSL Patches Vulnerabilities
Warning Software to Protect User
OpenSSL Vulnerable to Side Channel Attack
Voice Prints Could Secure Grid

However, in an IT environment, that is not necessarily the case. And now users have still not mitigated an OpenSSL vulnerability patched in early May with the release of versions 1.0.2h and 1.0.1t on some of the most visited websites.

By not patching, it is exposing potentially sensitive traffic to man-in-the-middle (MitM) attacks.

Security provider High-Tech Bridge used its free SSL/TLS testing service last week to determine how many of the Alexa Top 10,000 websites still suffer from the OpenSSL vulnerability (CVE-2016-2107).

The flaw first came to light in 2013 as part of the fix for the TLS attack dubbed “Lucky 13.” In April, Juraj Somorovsky discovered an MitM attacker can launch a padding oracle attack to decrypt traffic in cases where the connection uses an AES CBC cipher and the server supports AES-NI instructions.

“The bad news is that support of the AES CBC cipher is widely recommended for compatibility reasons, required by TLS 1.2 RFC and recommended by NIST guidelines. AES CBC cipher is also considered the strongest cipher for TLS 1.0 and TLS 1.1,” the security firm said in a blog post.

High-Tech Bridge conducted an automated, non-intrusive scan of the Alexa Top 10,000 websites by looking for the use of AES CBC and by using custom OpenSSL code specially designed to check for the existence of CVE-2016-2107.

The scan revealed that either web or email servers associated with 1,829 (18.29 percent) of the top websites vulnerable and exploitable. Researchers determined that 62 percent of servers (6,258) were not vulnerable, and 19.13 percent (1,913) were not exploitable.

“Taking into consideration that the vulnerability can be exploited in practice and allows stealing user data, credentials, financial and personal information, such results are pretty disappointing. We remind that the vulnerability can be easily fixed by updating your OpenSSL library and by rebooting your server afterwards. You can test if your web or email server is vulnerable to CVE-2016-2107 here.