Yokogawa’s Mitigations for CENTUM, Exaopc Hole

Friday, April 13, 2018 @ 10:04 AM gHale

Yokogawa has mitigations in place to fix a permissions, privileges and access controls vulnerability in its CENTUM series and Exaopc, according to a report with ICS-CERT.

Successful exploitation of this vulnerability, which Yokogawa, working with JPCERT, self reported, could allow a local attacker to generate false system or process alarms, or block system or process alarm displays.

RELATED STORIES
Omron Releases Update for CX-One
Mitigation Strategy for Rockwell’s MicroLogix
Siemens Updates Building Technologies Fixes
Philips Remediates iSite, IntelliSpace Holes

The following versions of Yokogawa products suffer from the issue:
• CENTUM series
o CENTUM CS 1000 all versions
o CENTUM CS 3000 versions R3.09.50 and prior
o CENTUM CS 3000 Small versions R3.09.50 and prior
o CENTUM VP versions R6.03.10 and prior
o CENTUM VP Small versions R6.03.10 and prior
o CENTUM VP Basic versions R6.03.10 and prior
• Exaopc versions R3.75.00 and prior
• B/M9000 CS all versions
• B/M9000 VP versions R8.01.01 and prior

In one vulnerability, a weakness in access controls may allow a local attacker to exploit the message management function of the system.

CVE-2018-8838 is the case number assigned to this vulnerability, which has a CVSS v3 base score of 6.5.

The products see action mainly in the critical manufacturing, energy, and food and agriculture sectors. They also see use on a global basis.

No known public exploits specifically target this vulnerability. This vulnerability is not exploitable remotely. An attacker with high skill level would be able to leverage the vulnerability.

Yokogawa created the following mitigations for the affected products.
• CENTUM Series
o CENTUM CS 1000, CENTUM CS 3000, CENTUM CS 3000 Small – No updates will be provided as these products are at end of support. Yokogawa recommended affected users upgrade to the latest CENTUM VP
o CENTUM VP, CENTUM VP Small, CENTUM VP BASIC – affected users should update to version R5.04.B2 or R6.04.00
• Exaopc – affected users should update to version R3.76.00
• B/M9000CS – The vulnerability does not exist in this product however, the existence of affected software on the same PC may affect alarms for this device
• B/M9000 VP – The vulnerability does not exist in this product however, the existence of affected software on the same PC may affect alarms for this device

Click here for more information in the Yokogawa Security Advisory Report YSAR-18-0001.



Leave a Reply

You must be logged in to post a comment.